no

The Maven Integration requires that Eclipse be running in jdk

"The Maven Integration requires that Eclipse be running in JDK, because a number of Maven core plugins are using jars from the JDK. P...

"The Maven Integration requires that Eclipse be running in JDK, because a number of Maven core plugins are using jars from the JDK.

Please make sure the -vm option in eclipse.ini is pointing to a JDK and vefify that Installed JREs are also using JDK installs".

If you happento encounter the error above, simply go to your eclipse installation. Open eclipse.ini and add the following line:

-vm
C:/YOUR_JDK_INSTALLATION_DIR/bin/javaw.exe

Take note the value is in the newline, if you will notice eclipse.ini accepts parameter on the second line. See the rest of the ini. Mine is:
-vm
C:/jdk1.5.0_22/bin/javaw.exe
-startup
plugins/org.eclipse.equinox.launcher_1.1.0.v20100507.jar
--launcher.library
plugins/org.eclipse.equinox.launcher.win32.win32.x86_1.1.1.R36x_v20100810
-product
org.eclipse.epp.package.jee.product
--launcher.defaultAction
openFile
--launcher.XXMaxPermSize
256M
-showsplash
org.eclipse.platform
--launcher.XXMaxPermSize
256m
--launcher.defaultAction
openFile
-vmargs
-Dosgi.requiredJavaVersion=1.5
-Xms40m
-Xmx512m

Related

java 496753929193470529

Post a Comment

5 comments

Anonymous said...

Thanks a lot, this helped me out!

Anonymous said...

Thanks for the information!

Anonymous said...

Thanks mate, appreciated

sreepal gummalla said...

Thanks for the configuration

Anonymous said...

Thank you. I had it in there, but VM was on the same line and it did not likey this!

item